Applicable to :
Operating system details : Solaris 9 9/05 s9s_u Generic_118558-11
Operating system details : Solaris 9 9/05 s9s_u Generic_118558-11
sshd version
Sun_SSH_1.0.1
Problem:
I was getting the following error while trying to open X window using xterm.
Even after enabling X11Forwarding in /etc/ssh/sshd_config , and restarting sshd daemon the problem was still there.
Solution:
Later i came to know
it was due to a bug with a particular ssh patch.
I got the following
messages in /var/adm/messages
Jun 4 20:38:17 PSBLD060 sshd[7646]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
Jun 4 20:38:40 PSBLD060 sshd[7647]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
Jun 4 20:38:48 PSBLD060 sshd[7648]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
Jun 4 20:39:13 PSBLD060 sshd[7870]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
Jun 4 20:40:38 PSBLD060 sshd[7873]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
Jun 4 20:44:58 PSBLD060 sshd[7941]: [ID 800047
auth.error] error: Failed to allocate internet-domain X11 display socket.
sshd syslogs the message error: Failed to allocate internet-domain X11 display socket. What it really means is that it failed to allocate any IPv6 listening sockets because you don't have IPv6 enabled, and it refuses to fall back to IPv4.
There
is a work around for this issue.
Just
add ipv6 loopback interface as follows
#
ifconfig lo0 inet6
plumb up
#
ifconfig -a
lo0:
flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
ce0:
flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
inet 10.1.18.169 netmask ffffff00
broadcast 10.1.18.255
ether 0:14:4f:24:d5:a4
lo0:
flags=2000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6> mtu 8252 index 1
inet6 ::1/128
#
/etc/ssh/sshd stop
From
ssh session itself we can do this you won't loose the session.
Then
run
#
/usr/lib/ssh/sshd -4
Now
try to connect using xterm it will work.
great
you have done.
Now
we will summarise.
#
vi /etc/ssh/sshd_config
X11Forwarding yes
#
ifconfig lo0 inet6
plumb up
#
/etc/init.d/sshd stop
#
/usr/lib/ssh/sshd -4
That
is it.

No comments:
Post a Comment